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	Overview


By now you’ve probably skipped this introduction and manically clicked on what few buttons are visible on screen. That’s alright, let it out.


As soon as you’re ready, we should cover some basics:



		Ulysses III is what we call an “enhanced plain text editor”. Everything you see — headlines, lists and emphasis — is just typed in. We will come back to this later.

		Ulysses III is a single-library app, and all your texts live in this single library. There is no “Open”, no “Save”, no Finder access — it all happens right inside this window. 

		Ulysses III fully utilizes iCloud, i.e. if you have iCloud set up and enabled, Ulysses will store everything on Apple’s super-modern mega-clusters. You can then access your texts from all of your Macs, as long (or as soon) as you’re connected to the web.

		Ulysses III does not offer WYSIWYG (What You See Is What You Get) styles and formats. Instead, your text will be automatically formatted once you export it as a PDF, a web page, or an eBook.




Most importantly, Ulysses III is built to grow and adapt. You can use it as a sophisticated notepad, you can create your next American Novel. You can feed your blog, keep everything neatly organized, or mess around at will.


There is no “right” way to do things here, so make yourself comfortable, and make it your own.


Ok, but how do I…?


If you have used any kind of three-pane-app before, you should have no problem navigating and using Ulysses. And if you’re familiar with the likes of Markdown and Textile, you should even feel right at home in the editor. There may be a few special cases where we’re handling things a bit differently, but all in all this should be rather common ground.


Anyway, UI-Overview from left to right:



		SIDEBAR

		SHEET LIST

		EDITOR




And that’s it.


The sidebar is divided into sections and should be pretty self-explanatory. Depending on whether you’ve got iCloud enabled, or whether you’re a user of Daedalus Touch, you will see different sections in the sidebar.


The sheet list is where all your texts reside.


And this here is the editor.


Sidebar: Groups & Filters


You add groups and filters via the sidebar’s plus menu. You can place groups and filters inside other groups. If you select a group in the sidebar, its contents will show up in the sheet list. Select a sheet, and it shows up in the editor.


Filters are a special kind of group. Once set up, they will look at the group they’re in and list all sheets that match the set criteria. For example, you can set up a filter that only lists sheets with a keyword of “fantastic”. If you place it deep within a nested group, say, six levels down, the filter will only show matching sheets within that very group.


You can even select multiple groups and filters (by holding down CMD), and get their combined contents listed in the sheet list. 


Sheets


All writing is done on Ulysses’ sheets. Sheets are somewhat equivalent to classic documents, though they don’t require a “title” or a “file name” or such.


You create sheets via CMD-N.


Sheets can hold any amount of text, and you can freely move sheets around and sort them at will. You can also select multiple sheets and glue them together (CMD-J). They will then behave as a single sheet in the editor, which is especially cool if you rather have a lot of small chunks than a single, monolithic wall of text.


You can also split a sheet in two at the current cursor position (Edit › Split at Selection), and merge two or more sheets together to form one (File › Merge Sheets)


Added bonus


Since sheets are likely to live in the vicinity of other sheets, we figured it would be nice if you could easily navigate between them — right from within the editor. There are keyboard shortcuts for this (CMD-ALT-up/down), but if you’re equipped with a Magic Mouse or trackpad, you can simply scroll to the top or bottom and “pull to switch”.


You should try this now to get the hang of it. Just come back here, as we’re about to look at the cool stuff.


Editor: Plain Text Enhanced


By now you should have noticed “all these funny characters” before headlines and within the text. You should also have noticed “these colored bubbles”, and wondered how they found their way into this otherwise format-free introduction.


You may even have marveled at how nice everything looks, how beautiful the text is set, how headlines are outdented and lists indented, and how all this is possible without using fancy formatting palettes, rulers and font panels. And, ultimately, what it all means, what it’s good for, and why you should care.


We believe that writers should not be bothered with layout tasks. At the very least, layout tasks should never interfere with the writing process itself. Call it what you will — distraction-free, zen-like, purely semantic, mini minimal, neo retro —, fact is that content creation is best kept separate from presentation, or else the latter will get in the way. Eventually. By design (pun, sorry).


Ulysses uses so-called minimal markup to define, not format or style, text passages. The full list of available definitions is accessible via CMD-9, and it should have you covered left to right. From headlines to lists, to images and footnotes, you simply assign meaning to text passages by entering some easy to remember shortcuts.


Need a title? Create a title.



Need a quote?


Create a quote.




Need a footnote? Create one.1 No need to reach for your mouse, just type. Just. Type.


Export: 360 degree semantics


Now for the fun part: Ulysses can output your writing to a host of standard formats, such as Plain Text, RTF, Word, HTML, ePub and even PDF. It does so by translating your plain text input based on the definition of the minimal markup. If your brain starts to hurt, here’s a simple example…


Let’s assume you want to emphasize a text passage. You select the word “emphasize” (do so), and press the keyboard shortcut CMD-I. Notice the extra characters that were entered around the word.


You have just told Ulysses, in its own “plain text language”, that this passage should be an emphasized passage. Now Ulysses knows and will never forget. So when you export your text to, say, a PDF, Ulysses will translate this emphasized passage into what a PDF will understand and display — in this case, it will format your emphasized passage as italicized text.


Give it a try:



		Open the export panel (CMD-6).

		Select the icon with the pen (Rich Text).

		Click the “Preview…” button.

		The “emphasize” above should be set in italics.




Headlines such as this will get a larger font


If you export to HTML instead, Ulysses will translate the emphasized passage to semantically correct <em>, and the headline will be tagged with <h2>. 


And so on.


The beauty of this should be obvious by now: Instead of worrying about how your output looks, you can concentrate on what your content is supposed to mean. This may be frightening at first, but trust us, it’s not.


It’s awesome.


Export: Styles


At the bottom of the Quick Export HUD, there’s an option to switch between various export styles. Each style offers a predefined set of conversion rules.


For example:


Headlines: Helvetica Neue, bold, 24pt.


Body text: Helvetica Neue, regular, 14pt.


Emphasis: Bold.


Images: Draw a border, 1pt, black.


Comments: Delete.


And so on. 


Ulysses features a couple of built-in styles for each exporter; you can check them all out in “Preferences › Styles”. Here, you can disable styles you don’t need, duplicate styles for editing, and even download and share new styles via the Ulysses Style Exchange. 


Attachments, Notes & Comments


There’s a bar atop every sheet which is called the “attachment bar”. Attachments allow you to place arbitrary content next to your not-so arbitrary main content: images, text notes, keywords and writing goals. Keywords are especially nice, since you can set up filters which will look for these keywords.


Images and text notes can be attached multiple times, and all attachments can be torn off and placed anywhere onscreen. You can even zoom into images, flip through PDFs and use most markup within text notes.


Another way to add notes is to create annotations or inline comments.  Comments can also span entire paragraphs.


Popovers


As you have seen, most of Ulysses’ advanced features are tucked away in small popovers. That way, they remain invisible unless you really need them. Most popovers can be torn-off and turned into always-on floating HUDs for quick reference and/or direct access. They make a good fit for a second monitor by the way.


And while some popovers are only available from within the editor, others can also be called in the sidebars. As an example, you can invoke Quick Export via the contextual menu on groups or filters. You can also check text statistics that way.


Pro tip: Quick Export, Favorites and Navigator feature full keyboard navigation. So if you feel like a power user, try this…


Hit CMD-8


Use up/down arrow to navigate


Try to select this headline


No, this one


THIS ONE!!!


iCloud vs On My Mac


In “Overview”, it states:



if you have iCloud set up and enabled, Ulysses will store everything on Apple’s super-modern mega-clusters




Well, we lied. It’s completely up to you where things get stored, and you can freely move your texts from the cloud to local storage only and vice versa.


As long as both options are enabled in preferences, that is:
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Obviously, everything stored in “On My Mac” will no longer be available on all the other Macs you own and use, but that’s not necessarily a bad thing, is it?


Integrating Daedalus Touch


If you own Daedalus Touch for iOS (and, frankly, you should), now is a good time to enable iCloud on your devices. We have natively integrated Daedalus into Ulysses’ sidebar, so there’s no setup necessary, no linking, nothing.


Daedalus’ stacks will show up as groups, and you can use most of Ulysses’ advanced features to continue the work you started on the road. Or the coffee shop. Or the beach. The bed. The couch. The Eiffel Tower. Mount Everest. ISS. Kepler 21b. So cool.


External Sources


Last but not least, you can even import and edit classic .txt and .markdown files, and have Ulysses keep them on your disk (i.e. outside Ulysses’ library). As an example, you can point Ulysses to a folder on your Dropbox, and have its contents behave just like native groups and sheets.


Some editor features will be limited (no images, no attachments), but that’s certainly negligible, compared to the alternatives. If we dare say so.


And… that’s… a wrap. You should now know enough to get around, and if you don’t, we have failed miserably.


So without further ado, you’re on your own.


Happy editing!


Basic Operation



		CMD-N to create a new sheet

		CMD-SHIFT-N to create a new group

		CMD-CTRL-N to create a new filter

		Items will always be created in vicinity to the current selection

		Sheets will be created below the currently selected sheet

		Groups and Filters will be created inside the currently selected Group 

		If there is no selection, or if the selection can’t accept new content (Library › All comes to mind), items will be created in the top-most category (e.g. iCloud)

		Click to select

		Double-click to edit




HUDs and Views



		CMD-1 to toggle sidebars

		CMD-2 to toggle sheet list

		CMD-3 to toggle editor-only view

		CMD-5 to show Favorites (FIVEorites)

		CMD-6 to show Quick Export (SIXport)

		CMD-7 to show Statistics

		CMD-8 to show Navigator (NavigEIGHTor, get it?)

		CMD-9 to show Markup Cheat Sheet




Quick Open Panel



		CMD-O to look for a sheet in the current section (iCloud, On My Mac, etc.)

		CMD-SHIFT-O to look for a sheet in the whole library

		CMD-ALT-O to look for a sheet in the currently selected group 




Global Search



		CMD-SHIFT-F to show sheet filter

		ESC to dismiss the sheet filter




Editor Find & Replace



		CMD-F to show Find panel

		CMD-ALT-F to show Find & Replace panel

		ESC to close Find/Replace panel




Editor Smart Paste



		CMD-Shift-V to invoke Smart Paste or

		Hold CMD-V to invoke Smart Paste


		
				Paste options will vary based on clipboard content and current Markup

				Arrow left/right to preview available paste options

				ENTER to confirm and paste 

		





Screen Modes



		CMD-ALT-P to toggle Pure Mode

		CMD-ALT-L to toggle Dark Theme

		CMD-CTRL-F to toggle Fullscreen Mode




Sheet List Options



		The View menu holds sevaral options for personalizing the sheet list:


		
				Set the “Sheet Preview” to anything between 1 and 6 lines

				Include Keywords and Goals in the sheet preview

				Either sort manually, by date or by first character

		





Editor Options



		The View menu also holds options for personalizing the editor:

		CMD-ALT-T to toggle Typewriter Scrolling


		
				You can set this to top, center or bottom

				You can also set this to be fixed or variable

		


		You can enable a highlight for the currently selected line

		You can enable the display of paragraph numbers




Font Size



		CMD-plus to increase font size

		CMD-minus to decrease font size

		CMD-0 to reset font size to default value




Markup



		CMD-# for Headlines

		CMD-I for emphasize

		CMD-B for strong

		CMD-L for links

		CMD-K for removing any sort of Markup (Kill)

		CMD-9 to show the Markup Cheat Sheet, in case you can’t remember any of this




Smart Tags



		If enabled, end tag placeholders will automatically be inserted whenever a start tag is followed by a character

		You can enable Smart Tags via Edit › Substitutions




End Tag Completion



		Press ESC to automatically enter an end tag placeholder

		To accept the end tag, do any of the following:


		
				Press Return

				Press Right Arrow

				Press Down Arrow (if at the very end of a sheet)

				Type in the end tag

		


		To dismiss the end tag, press ESC




Escape Character



		To keep Ulysses from treating any character as markup, just add a backslash in front of it (e.g., if you really want a square bracket instead of a link, type “[something]”)




Cheat Sheet



		When showing the Markup Cheat Sheet (CMD-9), you can click on any listed markup to apply it to the current selection

		This works with multiple selections (CMD-Click to select different parts of your text)

		Multi-level paragraphs, such as lists and block quotes, will get indented +1 every time you click

		Shift-clicking either removes the markup or outdents multi-level paragraphs




Lists



		TAB to increase list indentation

		SHIFT-TAB to decrease list indentation

		ALT-Return to automatically add another list item




Smart Lists



		If enabled, Return will automatically add another list item, while ALT-Return will just create a new paragraph

		You can enable Smart Lists via Edit › Substitutions




Media



		Drag’n’drop images, videos, PDFs into editor to create a text object which holds the item




Text Objects



		CMD-click to select

		Double-click to open popover




Text Object Popovers



		CMD-Return to close and move insertion point forward

		ESC to close and keep object selected

		TAB to switch between input fields

		Drag popover to tear it off and turn it into a floating HUD




Navigation, Sidebar



		Right arrow on groups to open group

		Right arrow on stack to switch focus to sheet list




Navigation, Sheet List



		Right arrow to switch focus into editor (placing insertion point at last edited location)

		Left arrow to switch focus into sidebar




Navigation, Editor



		At the start of a sheet:


		
				Double-tap up arrow to move one sheet up

		


		At the end of a sheet:


		
				Double-tap down arrow to move one sheet down

		


		Anywhere within a sheet:


		
				CMD-ALT-up arrow to move one sheet up

				CMD-ALT-down arrow to move to next sheet 

		


		Double-tap CMD-left arrow to switch focus into sheet list




Copy & Move in Sidebars



		By default, dragging groups and sheets to and from iCloud or “On My Mac” will always move, i.e. contents will get transferred to the new location

		Dragging to and from Daedalus and External Sources will always copy, i.e. contents will live in both locations afterwards

		Hold ALT while dragging, to force copy groups and sheets

		Hold CMD while dragging, to force move groups and sheets




Misc.



		CMD-S will create a new version of the current sheet. Select “Browse All Versions…” from the File menu to see how often you invoked that command

		CMD-J will glue together selected sheets (Join)


		
				If only a single sheet is selected, it will be glued to the previous sheet

				If there is no sheet above the currently selected sheet, nothing will happen, because nothing can

		


		You can permanently merge sheets via the “Merge Sheets” command from the File menu

		You can also split a sheet at the current cursor position by using the “Split at Selection” command from the Edit menu

		You can have multiple windows open at the same time (CMD-ALT-N)

		You can even have the same sheet visible in all open windows, which makes for some fancy show-off while editing, but it’s of not much use, to be honest

		Double-clicking a sheet in the sidebar lets you jump to the location of your last edit





	

	 Type (fn), put text into the popover, hit CMD-Return, continue.
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